Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 13, 2026 - 16:00 PST
Scheduled
We will be performing a scheduled maintenance as part of our Monthly Security Patch – February 2026.
Maintenance Window: 🕖 February 13, 2026 | 7:00 PM ET – 1:00 AM ET ⏱ Expected Downtime: Up to 6 hours Change ID: CHG1011974
During this maintenance window, services will be unavailable while the security patch is applied. We recommend planning accordingly and appreciate your understanding as we work to enhance the security and reliability of our platform.
Thanks, CRPM Support
Posted Feb 12, 2026 - 23:43 PST
This scheduled maintenance affected: Login & User Authentication, Web Application Service, Financial Modeling Service, Analytics, Document Management, Collaboration Services, E-mail Notifications, API, Support Portal, Tasks, My Tasks Widget, Box Desktop Client, Box Content API, Box Content Preview, Box Search, Box Webhooks, Box Uploads/Downloads, Box Authentication (OAuth 2.0 / JWT), Box Web Application, AWS ec2-eu-central-1, AWS ec2-us-west-2, AWS elb-eu-central-1, AWS elb-us-west-2, SendGrid SMTP, Mercatus Excel Plug-in, and Integration.