Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 14, 2025 - 16:00 PST
Scheduled
We will be applying a security patch to enhance system stability and protect against potential vulnerabilities. During this time, all services on the platform will be temporarily offline.
Date: November 14, 2025 Time: 7:00 PM ET – 12:00 AM ET (Approx. 5 hours) Impact: The platform will be unavailable during this maintenance window.. No user action is needed. Please plan your activities accordingly to avoid disruption.
Thank you for your understanding and cooperation.
CRPM Support
Posted Nov 13, 2025 - 07:25 PST
This scheduled maintenance affected: Login & User Authentication, Web Application Service, Financial Modeling Service, Analytics, Document Management, Collaboration Services, E-mail Notifications, API, Support Portal, Tasks, My Tasks Widget, Box Desktop Client, Box Content API, Box Content Preview, Box Search, Box Webhooks, Box Uploads/Downloads, Box Authentication (OAuth 2.0 / JWT), Box Web Application, AWS ec2-eu-central-1, AWS ec2-us-west-2, AWS elb-eu-central-1, AWS elb-us-west-2, SendGrid SMTP, Mercatus Excel Plug-in, and Integration.